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I. Introduction 
This documentation describes software for the analysis of single-molecule fluorescence and FRET 
(smFRET) data. Written in MATLAB, tools are included for extracting traces from movies, selecting 
traces according to defined criteria, applying corrections, hidden Markov modeling, simulation, and 
data visualization. This documentation provides a full description of core functions and some examples 
of their use. More details are available in the associated publication (Juette and Terry et al., Nature 
Methods 2016). 
 
Recommended system requirements: 

MATLAB (source code version): 2016b with Image Processing, Statistics, Curve Fitting, and Distributed 
Computing toolboxes. (Versions 2015a and later are also supported.) 

Operating System: Windows 7-10, Mac OS X Mavericks (or later), or Ubuntu Linux 14-16 (or similar) 

CPU: 64-bit Intel compatible x86 with at least four physical cores. 

Memory: 16 GB RAM. 

Storage: 100 GB free on a modern solid-state hard drive. 

 
Version numbers are formatted as MAJOR.MINOR.REVISION. Major versions break compatibility by 
changing file formats, core function syntax, or fundamental features. Minor versions add new features 
and fix bugs, but largely preserve compatibility. Revisions only fix bugs. 
 
 

II. Installation of the compiled version 
The compiled version of SPARTAN does not require MATLAB and is the easiest to set up.  
 

1. Uninstall any previous versions of SPARTAN. On Windows, navigate to “Start→Control 
Panel→Uninstall a program”. On Linux and Mac OS, simply delete the installation folder. 
 

2. Download and execute Install_SPARTAN and follow the on-screen instructions. On Linux, run in a 
terminal as root or install in your home folder. 
 

3. Once installed, to run SPARTAN on Linux, navigate to the installation folder and execute: 
./run_Cornell_SPARTAN.sh /path/to/MATLAB/MATLAB_Runtime/v85 
 
 

III. Installation of the source code version 
The source code version is more complicated to set up, but it also enables access to more functionality 
and allows the user to customize functions or write their own by interfacing with SPARTAN functions. 
 

1. Install 64-bit MATLAB 2016b with required toolboxes (see above).  
 

2. Download the latest version of SPARTAN source: http://www.scottcblanchardlab.com/software 
 

http://dx.doi.org/10.1038/nmeth.3769
http://dx.doi.org/10.1038/nmeth.3769
http://www.scottcblanchardlab.com/software
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3. Unzip the folder to some location such as “My Documents/MATLAB”. 
 

4. Open MATLAB, click on the “Set Path” button in the “HOME” toolbar panel. 
Click “Default” to removal all but the default code locations from the path. 
Click “Add with Subfolders” and select the SPARTAN source code folder. 
Click “Save” to keep the new path as the default and hit “Close”. 
 

 
 

5. Optional: download ebFRET version 1.1.1 and add the “src” folder to the MATLAB path. ebFRET 
will now be accessible in batchKinetics program as an additional Markov-modeling method. 
https://github.com/ebfret/ebfret-gui/releases/ 
 

6. Execute the command spartan at the MATLAB command prompt. 
 
 

Known issues (source code version): 

1. MATLAB may stall occasionally to start the parallel pool. To fix this, click 
the parallel icon in the lower-left corner of the main MATLAB window 
and select “Parallel preferences” and set the timeout to 1000 minutes. 
 

2. Some multi-processor computers may show long delays at the end of parfor loops. If you 
encounter this, set “constants.enable_parfor” to false in cascadeConstants.m to disable parfor. 

 
3. Other programs and user scripts on the MATLAB path may conflict with SPARTAN. If you 

experience a problem, first try resetting the path (see above) and ensure only one version of 
SPARTAN is on the path and no other files are on the path. It is also a good idea to keep the “My 
Documents/MATLAB” folder clear of .m files to prevent conflicts. 

 

4. If you encounter other problems, first try restarting MATLAB. If that does not work, contact us at 
scb2005@med.cornell.edu for assistance. Please include a full description of the problem. 

https://github.com/ebfret/ebfret-gui/releases/
mailto:scb2005@med.cornell.edu
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IV. Main menu and core analysis workflow (spartan) 

A main menu GUI (spartan) is provided for convenient access to key tools in the software suite. For 
compiled versions of the software, this window will appear when the program is launched. The current 
working directory is displayed in the textbox at the top and can changed by clicking the “Browse…” 
button. The general analysis workflow is as follows (described in detail in subsequent sections): 

1) Acquire wide-field fluorescence movies as a TIFF format image stacks. 

2) Run gettraces to extract fluorescence traces from the movies and calculate FRET. 

3) Run autotrace to examine trace statistics and select a subset of useful traces. 

4) Run makeplots to visualize the behavior of the ensemble of molecules. 

5) Run sorttraces to examine the behavior of individual molecules and select representative traces. 

6) Run batchKinetics to interpret FRET trajectories using hidden Markov modeling (HMM). 

7) Simulate traces in batchKinetics to evaluate if proposed models are consistent with experiments. 

 

For convenience, a GUI called spartan is provided to access all key functions from one place: 

 

Figure 1: SPARTAN main menu.
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V. Acquiring TIRF smFRET data 
Fluorescence microscopy data acquisition software may be obtained from the camera vendor, from 
one of the sources listed below, or custom software implemented in a program like LabVIEW. All of 
these programs perform a similar function – to read out frames from the camera(s) and save the data 
as an image stack in TIFF-format files. The output of most such programs should be supported by 
SPARTAN, but please contact us if you find a problem. 
 
https://www.micro-manager.org/ 
http://www.moleculardevices.com/systems/metamorph-research-imaging 
https://cplc.illinois.edu/software/ 
 
Below is a list of suggestions for instrumentation and data formats: 
 

1) Fluorescence channel arrangement: images from distinct spectral channels are generally tiled 
side-by-side in each frame (e.g., Cy3 left and Cy5 right). They can also be stacked sequentially 
(e.g., Cy3 in the first 1000 frames, Cy5 in the next 1000), but this requires modification to 
cascadeConstants.m to create a new profile for this purpose.  
 

2) Movie file format: movies should be saved as monochrome TIFF image stacks. The BIG-TIFF 
format (http://bigtiff.org/) should be used for sCMOS movies since they often surpass the 2GB 
limit of the original TIFF format. Best practice is to name movies using the following format: 
“YYMMDD sample-name experimental-condition.tif”. Each movie should have at least 50 
frames and typically 1,000 to 3,000. Specify the exposure time as a float in seconds in an 
“ExposureTime” EXIF tag (33434). If this tag is not found in a movie, the user will be prompted 
for it, which will interfere with batch processing. 

 
3) Immobilization: SPARTAN is tailored to experiments where donor fluorophore-labeled particles 

of interest are tethered to the surface and do not dissociate or move during the imaging period. 
Analysis of experiments with diffusing particles or with stage drift is not supported.  

 
4) Alignment: spectral channels should be as closely aligned as possible using fluorescent beads 

(Tetraspeck 0.1 μm, Invitrogen). SPARTAN’s automatic alignment will take care of the rest. 
 

5) Microscope: the microscope should feature stable, well-corrected optics, with each channel 
being precisely parfocal and flat. The illumination should be as even as possible within the field 
of view. The stage should be very stable and not drift within the imaging period. Finally, the 
objective correction collar should be adjusted for optimal PSF shape and intensity. 

 
6) Multiple cameras: cameras should be as identical as possible – for example with sequential 

serial numbers to ensure they were manufactured at the same time – and properly calibrated. 
The user also must ensure that the cameras are temporally synchronized, generally using an 
external trigger, and aligned on the same axis to avoid rolling shutter artifacts (sCMOS). 

  

https://www.micro-manager.org/
http://www.moleculardevices.com/systems/metamorph-research-imaging
https://cplc.illinois.edu/software/
http://bigtiff.org/
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Below are some additional tips for obtaining the best quality data: 
 

1) Hardware pixel binning: Care must be taken when enabling hardware binning on cameras that 
support it. Binning pools together groups of pixels that are read together before the data are 
streamed to the computer, reducing data size and analysis time. (With EMCCD cameras, binning 
can have the added benefit of increased SNR, since noise is introduced when each pixel is read, 
and may also increase maximum frame rates.) Keep in mind, however, that binning also 
generally reduces the maximum density of particles that can be immobilized, limiting 
throughput.  
 

2) Immobilization density: Small amounts of fluorescent background particles are often found on 
prepared glass imaging surfaces, generally at a low fixed density. When large numbers of 
fluorescent molecules of interest are immobilized, such particles do not contribute to the 
results. At very low densities, they may become a problem. To avoid this, it is best practice to 
occasionally take a movie under standard imaging conditions (including oxygen scavenging) to 
estimate the number of such particles and ensure an immobilization density at least 10-fold 
above this amount if possible. One should also avoid overloading the surface with particles, 
targeting a 40% overlap rate at most (see next section). 
 

3) Minimum intensity: Mean total fluorescence intensity should be at least 300 photons (20:1 
SNRBG) for best results. At very low signal intensity and SNR levels, some algorithms may fail. In 
particular, particles with a SNRBG less than 5 typically are not registered because the 
photobleaching step is small compared to noise. To increase SNR, increase illumination 
intensity, time resolution, or both. 
 

4) Fast photobleaching: If you acquire data in which the fluorophores photobleach substantially 
within 10 frames, some algorithms may not behave as expected. Specifically, gettraces uses a 
sum of the first 10 frames for detecting molecules. Molecules photobleaching within this 
window will appear dim and may not be detected, biasing the results. In such cases, you should 
reduce power (and increase integration time), use better-performing dyes, and/or improve the 
efficiency of oxygen scavenging. As a last resort, the user can also decrease the number of 
frames summed in gettraces to 4 with minimal changes in particle picking sensitivity. 
 

5) First frame drift: If you see changes in intensity within the first frame(s), consider removing the 
first frame(s) by changing settings in your acquisition software. Also ensure that shutter 
opening is optimally timed with the first frame exposure. 
 

6) Illumination uniformity: gettraces (next section) uses a single global threshold for detecting 
peaks of intensity associated with fluorescent molecules. If the illumination is non-uniform, 
molecules in regions with lower intensity may not be selected, possibly in a biased manner. 
Illumination intensity should decrease by no more than 30% from center to edge for optimal 
results. 
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VI. Extracting fluorescence traces from movies (gettraces) 
Using TIRF illumination, wide-field fluorescence movies are obtained that contain many point-spread 
functions (PSFs), each associated with the fluorescence emitted by a single fluorophore-labeled 
particle. The first steps in smFRET data analysis are to detect these peaks of intensity, assign PSFs in all 
spectral channels with fluorescence emitted from the same particle, sum the fluorescence intensity 
from each PSF to obtain fluorescence-time traces, and calculate properly-corrected FRET-time traces. 
gettraces performs these analysis tasks and can be accessed with the “Extract fluorescence traces from 
movies” button in the spartan menu. 
 

 

Figure 2: Screenshot of the gettraces program. 
 
 
1. Loading and viewing movies 
First, choose an Imaging Profile from the “Settings” menu box at the top of the window. Profiles 
describe the imaging setup, including spectral channel assignments and default analysis settings. Some 
of these settings can be changed using the “Customize” option at the bottom of the “Settings” menu or 
the  toolbar button. Field-specific settings can be changed by right-clicking on the desired field 
image and choosing “Change field settings.” They can be further customized by adding profiles to 
cascadeConstants.m in the SPARTAN source code. 
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To load a movie, click the  toolbar button or “File->Open” menu and choose a .tif image file. 
Summary images (average of first 10 frames) from each spectral channel and the sum of all channels 
(total intensity) will appear in separate fields. Background intensity, interpolated from areas of the field 
not containing PSFs, is automatically subtracted from these images to aid in PSF detection. The slider at 
the left side of the window changes the intensity scale, while the slider and “Play” button below the 
fields allows the user to scroll through frames in the movie. (Neither of these two options affect 
analysis results.) 
 
2. Detecting particles 
To detect fluorescent particles within the movie, click the  toolbar button or “View→Pick Peaks” 
menu option. The algorithm finds all local intensity maxima in the total intensity image that are 
brighter than a threshold above background levels. By default, the threshold is calculated automatically 
as a few standard deviations of background noise, but it can also be specified manually from the 
“Settings→Customize” menu. Circles mark the center of each detected PSF in each channel. 
 
Closely separated particles with overlapping PSFs must be excluded from analysis because the resulting 
signal contamination adds noise to the fluorescence traces. Gray circles mark such excluded PSFs. The 
minimum distance between PSFs is specified in the “Settings→Customize” menu. The fraction of 
rejected molecules, shown in the bottom-left of the window, should approach 40% for optimal loading. 
The number of particles selected for analysis is shown in the upper-right corner. The first number is 
selected molecules; the second one in parentheses is all molecules. 
 
3. Alignment of spectral channels 
By default, gettraces uses the Iterative Closest Points algorithm (ICP) to determine a mapping between 
corresponding molecules in each spectral channel (this can be changed using the “Alignment” menu). 
ICP iteratively finds a transformation that most closely overlays peaks across all spectral channels. 
Once the algorithm converges, PSFs are re-detected from the aligned total fluorescence intensity 
image to minimize any potential bias towards the brightest channel. 
 
ICP requires a strong signal on all spectral channels (0.2 to 0.8 FRET range). If one channel has little or 
no signal, ICP is likely to fail. It may also fail if there is a large number of contaminating fluorescent 
particles only visible on one channel. In such cases, you should record a short movie of fluorescent 
beads (TetraSpeck 0.1 μm, Invitrogen) at the beginning of the day, pick peaks using ICP, and click the 
“Alignment→Memorize” to use this alignment for all subsequent movies. A table in the lower-right 
corner lists the alignment transformation parameters used. “Deviation” is the average residual 
misalignment between the donor and acceptor PSFs and should ideally be less than 0.4 pixels. 
“Contrast” is the Weber contrast score of the total intensity image, relative to a scrambled image. A 
value below 1.1 is not much better than a random alignment, while 1.4 indicates high contrast from a 
proper alignment.  
 
4. Extracting fluorescence and FRET traces 
Fluorescence traces are extracted from the movie by summing the brightest pixels within a small 
region around each PSF. The size of the region around each peak to examine (“integration 
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neighborhood”) and the number of pixels summed can be specified from the “Settings→Customize” 
menu. The correct values for these parameters depend on the apparent PSF size, which is determined 
by magnification, physical pixel size, and other factors. The window size should thus be chosen so that 
~80% of the total PSF intensity is collected. This value is shown in the “% intensity collected” textbox, 
which is the fraction of summed vs. total intensity in the local region. The optimum value is a tradeoff 
between increasing signal intensity and background noise with each additional pixel. The user should 
use the value that results in the highest signal-to-noise levels in autotrace. 
 
Next, click the  toolbar button or “File→Save Traces” menu. Fluorescence-time traces will be created 
by summing over windows (see above) from each frame in the movie. Background levels after donor 
photobleaching are subtracted to more precisely zero the baseline. Donor to acceptor crosstalk is 
removed by subtracting a set fraction of donor intensity from the acceptor channel – this value can be 
changed by clicking the “Set Crosstalk” button. To correct for unequal acceptor channel brightness, the 
acceptor channel is scaled by a specified factor – this can be changed by clicking on the “Set Scaling” 
button. (For more information on these corrections, see the end of the next section). FRET-time traces 
are then calculated from the fluorescence traces, with FRET set to zero whenever the donor is dark, 
and saved in a “.rawtraces” file with the same name as the movie. 
 
5. Batch processing and automation 
The movie analysis process can be automated. To analyze all movies in a directory using the current 
settings, click the “Batch→Select Directory” menu. If the “Look in subdirectories” checkbox is selected, 
gettraces will also search for movie files in all subdirectories within the selected folder. If “Skip 
processed movies” is selected, any movies with an associated “.rawtraces” file will be skipped. To 
automatically detect and process new movies as they are recorded, click the “Batch→Auto-detect new 
movies” menu. This last option is useful for simultaneous data acquisition and analysis. During 
automated acquisition, the user is advised to continuously monitor the “Deviation” score, PSF size, 
fraction of rejected, etc, to ensure analysis is being performed correctly. 
 
Troubleshooting and tips 

• Diagnostic fields in gettraces will turn red when the value is outside the expected range. 

• Large PSF sizes, relative to the norm for the instrument, indicate poor or uneven focus. Optimal 
focus is very important for high data quality. If the focus cannot be improved, make sure all 
optics are fully cleaned and the correction collar is set to the optimal position. 

• If peaks are not detected at the edges of the field, the illumination may be low or non-uniform. 

• If molecules are rejected disproportionately at the edge or the deviation scores are high, there 
may be a problem with instrumentation, such as an improper correction collar position, dirty 
optics, non-flat focus across the field, or optical distortions in the light path. This might also be 
an indication of alignment problems. 

• Dim channels (Cy2 and Cy7) may show low contrast scores and warnings, even with a correct 
alignment (e.g., using beads). This is normal and arises from the low intensity of the channel. 

• Zoom in occasionally to check the alignment, especially when deviation scores are high.  
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VI. Select traces according to defined criteria (autotrace) 
One fluorescence movie can provide a wealth of information about the system of interest, often on the 
order of thousands of traces. The process of manually examining each individual trace to select those 
with sufficient lifetime and signal-to-noise ratios, remove those with well-defined artifacts, and 
summarize the ensemble behavior can be time-consuming and not completely reproducible. autotrace 
is designed to help automate this process by calculating statistics for each trace and displaying them as 
histograms to summarize the behavior of the ensemble of molecules. The user can then choose a set of 
criteria to select a subset of traces that meet those requirements – for example, minimum signal-to-
noise ratios and fluorophore lifetime before photobleaching. 
 
 
 

 
 
Figure 3: Screenshot of the autotrace program. 
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1. Loading files and displaying trace statistic distributions 

Click on the   toolbar button or “File→Open File” menu to load a single file or multiple files as a 
group. “File→Open Directory” will load all .rawtraces files in the selected directory – useful for 
combining a large number of equilibrium movies from the same condition. autotrace will calculate 
trace statistic values for every trace and compile the results into histograms. You can change the 
statistic that is plotted using the dropdown box above each histogram. The raw statistics can be saved 
to a text file for plotting in an external program by clicking the “File→Save Statistics” menu. A visual 
description of some statistics is below (Fig. 4). Algorithm details can be found in traceStat.m and new 
statistics can be added into this file seamlessly. 
 

 

Figure 4: Visual description of commonly used trace selection statistics. (a) Donor (green) and 
acceptor (red) lifetimes before photobleaching. “FRET lifetime” includes only stretches of 5 or more 
frames above the noise level (0.125). Detection of donor photobleaching is described in panel d. (b) 
Calculation of two types of mean total fluorescence intensity (MTI) and signal-to-noise ratios (SNR). (c) 
Pearson’s correlation coefficient of donor vs. acceptor fluorescence traces over the region prior to 
donor photobleaching, with several example traces that display different degrees of dynamics and 
therefore anti-correlation. (d) Detection of photobleaching steps is achieved by summing all 
fluorescence channels (third panel from top, gray), median-filtering this signal (black), calculating the 
gradient (last panel), and finding the large, negative changes in this signal that occur when the total 
intensity drops suddenly. (e) For pre-steady-state measurements, selecting traces that start in low-
FRET states and achieve a particular high-FRET state are useful criteria to isolate “productive” events. 
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2. Choosing selection criteria 
To select a subset of traces, use the selection criteria controls at the right side of the window. The most 
commonly used criteria are listed under “Standard Selection Criteria,” with checkboxes to specify 
which criteria to apply. Additional selection criteria can be chosen under “Specialized Selection 
Criteria.” Each line is a potential criterion, including the statistic name, an equivalence, and a value for 
the criterion (e.g., Donor lifetime > 50). Press Enter to ensure a change is registered. Any lines in which 
one box is empty are not applied. As criteria are added or changed, the subset of selected molecules 
will change accordingly, reflected in the number of selected molecules (top-right of window), and the 
histograms displaying the distributions of statistics. These histograms only show the values for selected 
molecules, not the entire dataset. 
 
3. Saving selected traces 
To save the subset of traces that pass the selection criteria, click the  toolbar button or “File→Save 
Traces” menu and choose a destination filename, typically ending in “_auto.traces”. A “.log” file will 
also be created that that lists the files loaded, selection criteria applied, number of traces selected, and 
a breakdown of how many passed each criteria. To examine individual traces with the sorttraces 
program, click the  toolbar button or select the “View→Traces” menu. To view the ensemble as a 
contour plot with the makeplots program, click the  toolbar button or select the “View→Contour 
Plot” menu. 
 
4. Batch mode 
The process of loading a file and saving selected traces can be automated by selecting the 
“Batch→Batch Analysis” menu. For each .rawtraces file found in the selected directory and all 
subdirectories, autotrace will select traces according to the current criteria and save a corresponding 
“_auto.traces” file. This function is particularly useful when new selection criteria have been 
established and a large amount of experimental data must be reprocessed. The “Batch→Auto-detect 
new files” menu will automatically process new .rawtraces files as they appear in the target directory, 
useful for real time data analysis. 
 
5. Post-processing: ensemble-level spectral corrections 
Initial spectral corrections made in gettraces (see above) use pre-defined values, but these may need 
finer adjustments to correct for variability between samples. These adjustments can be made in 
automated ways using crosstalkcorrect and gammacorrect, or manually using sorttraces. 
crosstalkcorrect automatically finds the degree of donor to acceptor spectral bleedthrough (crosstalk) 
and corrects for it. gammacorrect scales the acceptor channel so that the apparent brightness of the 
two channels is equal. Both methods estimate a single ensemble-average correction value for each file 
and applies it to all traces in that file. This approach is not effective in correcting for wide variation in 
these parameters, which may require manual adjustments in sorttraces (see the next section). Note 
that since gammacorrect is less stable than applying a fixed value, it may be better to use 
gammacorrect to establish an average value that can be applied to all data consistently in gettraces. By 
contrast, crosstalkcorrect is unlikely to increase variability in FRET values. 
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VII. Manually viewing, corrections, and select traces (sorttraces) 
 

 
 
Figure 5. Screenshot of the sorttraces program. 
 
 
1. Loading and examining .traces files 

Click on the  toolbar button or select the “File→Open” menu to view a .rawtraces or .traces file. At 
top are the fluorescence traces. In the middle is total fluorescence intensity (black line), along with a 
blue line that defines the total intensity threshold, below which FRET is fixed at zero. At bottom are the 
FRET trace (blue) and idealization (red). The filename and current trace number are displayed at the 
top. Use the controls in the “Navigation” panel at the bottom-right to navigate to the “Previous” and 
“Next” particles in the file. Use the textbox between these buttons to jump to any specified trace. 
 
Some trace statistics are also displayed for reference in the “Info” panel in the middle/right: 

• Lifetime: donor and acceptor lifetimes before photobleaching (in that order). 

• Correlation: Pearson’s correlation coefficient of the donor and acceptor traces while the donor 
is alive. The right panel is the correlation coefficient for the current zoomed region of the trace. 

• SNR: magnitude of total fluorescence intensity divided by the s.d. of background after donor 
photobleaching (left) and the total intensity signal before photobleaching (right). 
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• Molecule location: a red circle shows the position of the particle within the field of view. 
 

2. Manual trace selection 
Traces can be assigned to bins (“No FRET”, “All FRET”, and “Best FRET”) using the checkboxes in the 
“Binning” panel. The bin names are arbitrary, but typically “No FRET” traces have major artifacts that 
cannot be used for further analysis, “All FRET” traces will be used for further analysis, and “Best FRET” 
traces are representative examples selected for publication. The number of traces in each bin is 
displayed above each checkbox. The bins can be renamed by right-clicking on the bin checkbox and 
choosing “Rename Bin.” This menu has other options, such as clearing selections in a bin and moving 
to the next molecule within a bin. 
 
3. Saving selections 
To save the selected traces, click the  toolbar button or “File→Save Selected Traces” menu. This will 
create one file for each bin (“…_no_fret.traces”, etc.), overwriting any existing files. If any bin is empty 
(zero selected traces), no file is saved and any existing file is deleted. The selected trace numbers and 
any adjustments made to the data are saved in a “…_savedState.mat” file so the user can return to the 
process at a later time. 
 
4. Idealization 
Sorttraces will automatically look for an idealization file with the same name as the .traces file, but 
with a .dwt or .qub.dwt extension. These files are created with batchKinetics in SPARTAN, QuB, or after 
conversion from another program such as HaMMy[2] or ebFRET[3]. No adjustment to the idealization 
can be made within sorttraces. Click on the  toolbar button or “Edit→Load Idealization” menu to 
load an idealization from file, or “Edit→Clear Idealization” to remove it. If an idealization file is loaded 
when the user saves selected traces, corresponding .dwt files will be saved for each output .traces file 
containing the idealizations of the selected traces. 
 
5. Making corrections to adjust for non-ideal properties of real-world data: 
 

• Background Subtraction: To set the baseline fluorescence level to zero after photobleaching, 
zoom in on a background region and click the  toolbar button or “Corrections→Subtract 
All” menu. Click the “Corrections→Reset Background” menu to undo this change. 

• FRET Threshold: FRET is set to zero below this threshold, which is displayed as a blue line in 
the middle plot. Turn off the zoom ( ) control and drag the line to adjust. The blue line 
should cleanly separate the fluorescence when the donor is fluorescent vs. dark. To automate 
this process, you can use the “SKM” option, which uses hidden Markov modeling, from the 
“Edit→Set Zero Method” menu. This option can also be changed in gettraces. 

• Spectral crosstalk between fluorescence channels is corrected by subtracting a set fraction of 
the bluer channel from the redder channel. The “D/A crosstalk” control adjusts this value for 
donor to acceptor crosstalk. With the correct value, the acceptor fluorescence level after 
acceptor photobleaching should be zero and will not change upon donor photobleaching. The 
“D/A2” and “A1/A2” adjustments correct for additional pairs of channels with 3-color FRET. 
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• Uneven apparent brightness of spectral channels is corrected by scaling the acceptor 
channel(s) by the factor given in the “A1 Scaling” (and “A2 Scaling”) controls. These should be 
adjusted so that the total intensity is constant during FRET changes [1, 4]. 

 
.traces files are saved with all corrections applied, exactly as they appear. If you want to save the entire 
file with corrections, rather than a few selected traces, click the “Save current file as…” button. To 
reset the entire file to its original state click on the “Corrections→Reset All” menu.  
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VIII. Visualizing trace ensembles 
makeplots is a program for visualizing the ensemble of single molecule behaviors using a set of 
standard plots. The first row contains FRET-time contour plots, which show the evolution of the system 
over time, along with the number of molecules in the file. In equilibrium experiments, these will be 
constant except for accumulation at zero FRET efficiency due to photobleaching. If no idealization data 
is available, the second row contains FRET histograms summed over the time span in the contour plots 
(use frethistComparison to overlay these histograms). If an idealization (.dwt) file is found with the 
same name as the .traces file, the second row of plots contains a set of overlaid FRET histograms, one 
per FRET state, along with the total histogram as a black line. The third row contains transition density 
plots [2], the total number of transitions (Nt), and the average transition rate (t/s). 
 
Note that the TD plots generally include all data in the file, not just the window shown in the contour 
plots. This behavior and other settings can be changed from the “Edit→Settings” menu. These settings 
will be remembered for all future calls to makeplots. To reset all settings to their defaults, click on the 
“Edit→Reset settings” menu. Clicking the “File→Export .txt files” menu will create text files of the 
histogram data for plotting in external programs such as Origin. 
 

 

Figure 6: Ensemble plots generated with the makeplots program.  
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IX. Hidden Markov modeling (batchKinetics)  
Interpretation of smFRET data often requires two key tasks: 1) to define a model that fully describes 
the behavior of the ensemble of particles and 2) for each particle, estimate the state of the underlying 
physical system at each point in time given the observed smFRET data (idealization). The model defines 
states (conformational or compositional) defined by their specific FRET values and noise characteristics 
(observation model) and the rate constants that describe the dynamic exchange between states 
(kinetic model). These tasks are generally accomplished within the framework of hidden Markov 
modeling [5]. A number of programs, some listed below, are available for Markov modeling of smFRET 
data. QuB has a long history success for the analysis of ion channel recordings, which are similar in 
many ways to smFRET traces, while the others are newer programs designed specifically for smFRET 
data. batchKinetics in SPARTAN implements some of these methods and provides tools for Markov 
modeling. 
 

QuB http://www.qub.buffalo.edu/ 
HaMMy http://bio.physics.illinois.edu/HaMMy.asp 
ebFRET http://ebfret.github.io/ 
SMART https://simtk.org/home/smart 

 

 

Figure 7: Screenshot of the batchKinetics program. 

http://www.qub.buffalo.edu/
http://bio.physics.illinois.edu/HaMMy.asp
http://ebfret.github.io/
https://simtk.org/home/smart
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1. Select the smFRET data files to analyze 
First, select the .traces files to analyze by clicking on the  toolbar button or “File→Load traces” 
menu. The files will be listed in the textbox under the “Files to analyze” heading at the top left. Traces 
from the currently-selected file will be displayed on the right side (blue) with the idealizations if 
available (red). The scroll bar at the far right can be used to scroll through the files. The scroll bar at 
bottom can be used to zoom in on the beginning of the movie. 
 
2. Loading and reshaping an initial model 
Second, load an initial model for fitting and optimization. Click the  toolbar button or “File→Load 
Model” menu and choose a .qmf file. (These files can be created with QuB). A schematic 
representation of the model will be displayed on the right side, with a similar appearance and 
functionality to the model panel in QuB. Each box is a state, marked with the state number in the 
center. The color of each box corresponds to the class number, which describes distinguishable FRET 
states. Lines between states describe rate constants of transitioning from one state to the next, 
indicated by the direction of the arrow.  
 
Model parameters can be changed by right-clicking on a state and choosing “properties.” Class 
properties (emission parameters) are also displayed in the table in the lower-left corner. Checking 
boxes in the “Fix” column will prevent that parameter from being changed during fitting (sometimes 
useful for states that have unusual characteristics, especially the zero-FRET state). Rate constants can 
be altered by double-clicking on the text. States can be moved by dragging them. New connections can 
be made by right-clicking on a state and choosing “Connect to.” Any changes made to the model can 
be saved by clicking on the  toolbar button or the “File→Save Model As” menu. Alternatively, 
changes can be undone by right-clicking on the model panel and choosing “Revert to saved.” 
 
3. Select the analysis method and execute 
Several analysis methods are available, including those in QuB and developed by others for smFRET: 
 

• SKM (segmental k-means) [6] uses a crude model optimization method to idealize traces rapidly. 
(As such, it is not used to directly estimate kinetic parameters.) SKM is most useful when the 
emission parameters and model connectivity are established and only the rates are expected to 
change between conditions. This algorithm is sensitive to the initial model parameters (particularly 
FRET values), and as such is not well-suited to discovering a new model.  

• MIL (maximum interval likelihood) [7] optimizes a kinetic model (rates) given an idealization. This 
method is generally coupled to SKM for data with widely separated states with high data quality, 
where the user wishes to infer an optimal kinetic model that explains the idealized data. 

• Baum-Welch [5] optimizes the full model from input smFRET data, without the information loss of 
using idealizations as an intermediate like MIL. It is more powerful and less sensitive to the starting 
model than SKM, but requires considerably more compute time and converges slowly. 

• ebFRET [3] uses a Bayesian approach to discover a model that best explains the observed FRET 
data. This method is slow, but very powerful in that it requires no initial model – only a number of 
states. (The GUI model only specifies the number of states.) ebFRET is an iterative version of 
vbFRET [8] that uses the posterior probabilities to refine the priors for each iteration. 
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MIL and Baum-Welch optimize a single model to explain all traces. SKM optimizes each trace 
separately (can be changed from the “Edit→Analysis Settings” menu) to correct for subtle differences 
between each molecule. ebFRET uses a hybrid approach. One disadvantage of fitting each trace 
separately is that it can result in overfitting if the traces are too short to describe the full spectrum of 
possible states and transition types. Generally this means that every trace should show sampling of all 
FRET states many times, which is not always possible. 
 
Once the model and data are loaded and all the settings have been chosen, click on the  toolbar 
button to run the analysis procedure on the currently-selected file. After completion, the new 
idealization, if applicable, will be displayed over the traces. If the “Update model parameters” 
checkbox under “Analysis settings” selected, the model will reflect the fitted optimal ensemble model. 
The kinetic parameters are particularly valuable in examining the physical basis of perturbations on a 
biological system. 

 
4. Visualizing the results 
SPARTAN provides a variety of tools to visualize the results of Markov modeling. These are available 
from the “Plot” menu and from the toolbar ( ) and include displaying dwell-time 
distributions (dwellhist); FRET-time contour plots, per-state FRET distributions, and transition density 
plots (makeplots); occupancy in each state (percentTime); evolution of state occupancy over time 
(occtime), useful for pre-steady-state measurements; and average transition rate 
(transitionsPerSecond; not in toolbar). 
 
5. Simulation of smFRET data 
batchKinetics can also be used to simulate smFRET data according to the currently-loaded model. This 
feature is primarily useful to test the validity of a model derived from hidden Markov modeling of 
experimental data by evaluating if the features of the simulated and experimental data match (e.g., 
state occupancy, transition density plots, etc). It can also be useful to understand how stochasticity and 
specific artifacts contribute to non-ideal behavior in smFRET data. The results approximate 
experimental data as closely as possible, but are not intended to be a faithful reproduction of the 
physics involved. 
 
To simulate traces, load a model and click the  toolbar button or the “Action->Simulate Traces” 
menu. A dialog will appear with simulation parameters, including the number of traces, intensity, SNR, 
and photobleaching rate (see the next section for a full description of all parameters). Finally, choose a 
filename to save the simulated traces. They will then also appear in the batchKinetics window. 
 
Next, specify the number of traces, length of each trace (in frames), and the time resolution (in ms) of 
the simulated data. When the data are simulated, each trace will initially consist of a series of 
continuous-time dwells in the model states. FRET data are then generated by summing the 
contributions of all dwells within each frame at the final time resolution, accounting for time averaging 
due to dynamics faster than the imaging rate. 
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6. Parameters for the simulation of fluorescence traces and noise 
These parameters are used to simulate fluorescence-time traces from the simulated FRET-time 
trajectory. In general, these values can be obtained from the mean statistic values observed with 
autotrace for gamma-corrected data you wish to reproduce. 

• Total intensity: observed average total (donor+acceptor) fluorescence intensity in photons of 
each trace prior to photobleaching. The effect of non-uniform illumination can be simulated 
with the second textbox, which defines the standard deviation of this distribution. 

• Signal-to-background noise ratio (SNRBG): controls the amount of Gaussian white noise added 
to the fluorescence data to simulated background noise. NOTE: when simulating wide-field 
movies, this parameter should be high (>100) because background noise is added with the 
background movie. 

• Shot noise: if checked, Poisson shot noise, which arises from the uncertainty of photon 
counting statistics, will be simulated by drawing Poisson-distributed numbers at each frame, 
with the mean being the underlying fluorescence value. 

• Photon noise stdev: Use this parameter to modulate the fluorescence intensity in each channel 
with Gaussian-distributed noise. This is sometimes useful to approximate photophysical noise, 
but it is not a very good approximation. 

• Apparent Gamma: specifies the apparent brightness of the donor relative to the acceptor, 
simulating the effects of unequal quantum yield and detection efficiency. A value of 0.5, for 
example, means that the acceptor is half as bright as the donor. If this value is not unity, the 
mean total intensity in autotrace will only match the simulated value after gamma correction. 

• Total time on: specifies the average lifetime of the acceptor fluorophore prior to 
photobleaching, which determines the useable length of each FRET trace. Donor 
photobleaching is also simulated, with a rate that is ½ of the specified value. 
 

7. Simulating wide-field movies (optional) 
To most faithfully reproduce the qualities of real data, wide-field fluorescence movies can also be 
simulated. This method requires that a background movie be acquired under exactly the same 
conditions as the target experiment, except that the biological sample is not immobilized on the 
surface. 

• Grid: if this checkbox is selected, fluorophores will be placed on a regular grid of positions, 
separated by the widest possible margin to achieve the target number of fluorophores per 
movie. Each position is then randomly perturbed by up to 1 pixel to simulate the effect of 
fluorophores not perfectly aligning to pixel boundaries, as in experiments. 

• Density: specifies the number of particles to place within the field of view.  

• Point-spread function size: specifies the size (standard deviation, in pixels) of the symmetric 
Gaussian point-spread functions. Each simulated trace’s intensity is distributed across a region 
of the field of view, centered at the fluorophore’s actual location. Choose a value so that 
gettraces shows the same effective PSF size (counted in that case as the number of pixels to get 
80% collected intensity) as the target experimental data. 
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• Field alignment: use these parameters to define misalignment between the two spectral 
channels. The values can be derived using gettraces and example data. 

 
8. Output 
When the “Simulate…” button is clicked, a progress bar will appear that estimates the time remaining 
for the computation. If the rate constants in the model are much faster than the imaging rate, this 
computation can take minutes. Once finished, several files are generated, all with the same base name 
as the output filename chosen by the user: 
 

• ___.sim.log: documents the settings used for generating the simulated data. 

• ___.sim.dwt: simulated dwell-times, which may be much shorter than the actual imaging time 
resolution. Because of limitations in the .dwt file format, all times are rounded to integer 
milliseconds. 

• ___.traces: simulated single molecule fluorescence- and FRET traces. If simulating wide-field 
movies, this may not be useful. 

• ___.tif: wide-field fluorescence movie, if requested. 

 
9. Troubleshooting and tips 
Dwell times are drawn from continuous exponential distributions and FRET traces are calculated by 

summing the contributions of all dwells occurring within each frame. This allows accurate simulation of 

models with rate constants faster than the imaging rate (time resolution). Other programs, such as 

QuB, can only produce discrete-time series without time averaging and as such are not directly suitable 

for such models. 
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X. Analysis pipeline for pre-steady-state experiments (rtdgui, rtdTool, and rtdPlots) 
Pre-steady-state smFRET experiments are carried out by real-time delivery (RTD) of reagent to surface-
immobilized molecules. Turnover of the monitored reaction coordinate proceeds in a non-
synchronized fashion with a distribution of waiting times. rtdgui is a tool to analyze and display the 
synchronized time evolution of an asynchronous non-equilibrium ensemble. It takes as its input any 
trace file, typically a “.rawtraces” file generated by gettraces, and performs the following steps in an 
automated fashion: 
 

1. Select traces according to a set of criteria using autotrace. In addition to typical default 
criteria, traces that start out with FRET efficiencies greater than a low-FRET threshold are 
excluded to remove molecules that have already turned over at the beginning of the movie. 

2. Post-synchronize FRET events to the first appearance of FRET. This point is determined by 
idealizing the data to a simple “on/off” two-state model using SKM. 

3. Idealize the post-synchronized events using a kinetic model appropriate for the system (see 
batchKinetics documentation for details). By default, this uses a model for aa-tRNA selection 
monitored using tRNA-tRNA FRET, by a custom model for any system can be provided by 
the user. 

4. (Optional) Split the post-synchronized “.traces” file into two populations termed productive 
and non-productive. Productive events are those that spend a given minimum dwell time in 
a specified state. In the case of aa-tRNA selection, this identifies successful accommodation 
events. 

5. Generate an informative set of plots for each population (this is an extension of makeplots). 

 
 

 
 
Figure 9: Screenshot of the rtdgui dialog.  
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1. Defining settings and running the analysis pipeline 
In the rtdgui dialog, select a kinetic model appropriate for your experiments. By default, the kinetic 
model for aa-tRNA selection in E. coli (using the tRNA-tRNA FRET signal) is selected. Click “Browse” or 
type a path to seect a different model. Models need to be in the “.qmf” format generated by QuB. 
 
In the next section, “Event separation”, enable the checkbox if you want events to be classified into 
productive and non-productive events, based on a minimum dwell time in a specified state. You can 
select the “productive” state in the dropdown and type in a minimum dwell time in milliseconds in the 
field underneath. 
 
Click “Run” to bring up a file selection dialog and choose any “.rawtraces” or “.traces” files that you 
want to process. The dialog reappears to allow multiple selections until you hit “Cancel”. At that point, 
the automated analysis procedure starts running. Depending on your computer and the selected files, 
this can take anywhere from a few seconds to several minutes. If you are running the program within 
MATLAB, update messages will appear in the command window. 
 
When processing is completed, a visualization window with multiple columns of plots is launched. Each column 
corresponds to one output “.traces” file. If event separation is active, each input file generates three columns: 
“all events”, “productive events”, and “non-productive events”. The first three rows of plots are identical to the 
output that makeplots would generate (FRET-time contour plots, overlaid FRET histograms for the FRET states 
contained in the model, transitions density plots summarizing the FRET values immediately before and after 
observed state transitions). The last row shows the occupancy of each state (including the no-

FRET/photobleached state) over time, using the same color scheme as the second row. 
 
 

 
 
Figure 10: Post-synchronized ensemble plots generated with the rtdgui program. 
 

Visualization window layout 

 

Post-synchronized ensemble plots 

All events Productive Non-prod. 

 

FRET state histograms 

All events Productive Non-prod. 

 

Transition density plots 

All events Productive Non-prod. 

 

State occupancy over time 

All events Productive Non-prod. 
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2. Reviewing plots for previously processed data 
In order to bring up the visualization window for already processed data, click “Remake plot for already 
processed files” in rtdgui and select all “.traces” files to be included in the plot window. This feature 
can also be called directly from the MATLAB command line by typing “rtdPlots”. 
 
3. Customization and advanced settings 
rtdgui can optionally load advanced settings from file by enabling the corresponding checkbox and 
selecting an appropriate file. This allows the user to better adjust parameters for the different steps of 
the analysis to their specific data, or to programmatically specify which files to analyze (bypassing the 
file selection dialog). This functionality is currently only available in the source code, not in the 
compiled version of the software. The settings file is a MATLAB script (“.m” format) that builds a 
“customOpt” structure containing the user-specified settings. For details, including allowed entries and 
an example, refer to the file “advanced_settings_example.m” in the rtd2 directory of the source code. 
 
Alternatively, the core function performing the RTD analysis, rtdTool, can also be called directly from 
the MATLAB command line or in scripts. Type “help rtdTool” for more information. 
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XI. Customization 
In some cases, users will need to change the behavior of certain functions for which there are no 
convenient GUI controls. cascadeConstants.m contains nearly all parameters in the software suite. 
Keeping all settings in a single location ensures only a single file is ever modified by the user, making 
changes more traceable. More detailed descriptions of each setting are available in 
cascadeConstants.m. The file is broken into several sections: 
 
1. Global: these may apply to many functions. 

 
2. Gettraces: default settings for each of the imaging profiles, including some settings that cannot be 

changed in the GUI. With some care, new profiles can be added without disrupting the other 
profiles in the list. Note that some settings common to several profiles are defined at the beginning 
of this section. 
 

3. Autotrace: defines the default criteria and parameters used for calculating statistics in traceStat.m. 
 

4. Makeplots: plotting settings such as the number of frames to display in FRET-time contour plots. 
Includes some settings unavailable in the GUI. Some other plotting functions such as 
frethistComparison also use these settings. 
 

5. Other: miscellaneous settings. Of note, this is where you can turn off parallel processing. 
 
Despite our best efforts, some settings may need to be modified within individual functions. 

 
New statistics for autotrace can be made relatively easily by altering traceStat.m. Any new statistic 
added to the output struct array (and the statistic description struct) will be recognized seamlessly by 
autotrace. 
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Appendix A. Full list of MATLAB functions 
The software includes a large number of MATLAB functions, including some for specialized purposes. 
Below is a list with a brief description of each. To find out more about each program, type “doc 
function” with the name of the function at the MATLAB command prompt. Lines in gray are internal 
functions that are rarely or never used by end users directly. 
 

 
 
Figure 11: schematic overview of key MATLAB functions. 
 
 
Gettraces: 
1. gettraces_gui: user interface for loading movies and extracting fluorescence traces. 
2. gettraces: command-line backend function used for all computation in the above. 
3. getPeaks: find molecules in each each channel, including alignment.  
4. pickPeaks: discover local intensity maxima associated with immobilized, fluorescent particles.  
5. icpalign: iterative closest points algorithm for aligning fluorescence fields. 
6. getIntegrationWindows: find brightest pixels in the local area around local intensity maxima 
7. getCentroids: fast, approximate calculation of center of mass of each PSF.  
8. subfield: quick way to extract a quadrant or sub-field by name (e.g., TL=top left). 
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9. translatePeaks: transform reference (donor) PSF positions to get expected acceptor PSF positions. 
10. weberQuality: Weber contrast score for quantifying the quality of an alignment. 
11. Wavelength_to_RGB: produce an RGB color that mimics light of a particular wavelength. 
 
Autotrace: 
12. autotrace: user interface for viewing trace statistic distributions and saving selected traces. 
13. traceStat: calculates values of statistics for each trace in a dataset. 
14. calcLifetime: find the donor photobleaching point; used by traceStat. 
15. medianfilter: sliding window median filter, used by calcLifetime. 
16. rleFilter: set to zero stretches of binary data that are not longer than a specified length 
17. RLEncode: run-length encoding 
18. pickTraces: select a subset of traces according to defined criteria. 
19. loadPickSaveTraces: load traces file(s) and save traces picked according to defined criteria. 
 
Trace corrections: 
20. bgsub: subtracts fluorescence after photobleaching to zero the baseline level. 
21. crosstalkcorrect: correct for donor-to-acceptor spectral crosstalk (one value per file) 
22. gammacorrect: correct for unequal donor and acceptor apparent brightness (one value per file) 
23. scaleacceptor: similar to gammacorrect, but a scale by a factor specified by the user. 
24. correctTraces: internal function to apply corrections in a consistent order. 
 
Visualization: 
25. sorttraces: visual inspection, correction, and selection of individual traces. 
26. forOrigin: save traces as a text file to be imported into Origin for making publication-quality figures. 
27. makeplots: displays FRET-time contour plots, state occupancy, and transition density plots. 
28. makecplot, cplot: calculate and display FRET-time contour plots from FRET traces. 
29. statehist: calculate FRET histograms for each idealized state (middle row in makeplots) 
30. tdplot, tplot: create and display transition density plots. 
31. frethistComparison: overlays FRET histograms from multiple files for direct comparison. 
32. avgFretTime: displays the change in average FRET value across all traces over time. 
33. occtime: state occupancy over time, averaged over all traces. 
34. percentTime: calculate the fraction occupancy in each FRET state from a .dwt file. 
35. dwellhist: displays FRET state lifetimes, as exponential or Sine/Sigworth plots, from multiple files. 
36. lifetime_exp: Fits the exponential decays to get average dwell-times, using dwellhist.  
37. transitionsPerSecond: average number of transitions per total time over entire file. 

  
HMM: 
38. batchKinetics: GUI for idealization, model optimization, and kinetic analysis. 
39. skm, idealize, forward_viterbi: segmental k-means and Viterbi algorithms for idealization.  
40. qub_milOptimize: use QuB’s maximum interval likelihood algorithm to optimize a kinetic model. 
41. BWoptimize, BWiterate, BWtransition, BWbackward, BWforward: Baum-Welch algorithm.  
42. runEbFret: runs ebFRET (external program installed on path). 
43. simulate_gui, simulate: simulate smFRET data. 
44. simulateMovie: simulate wide-field TIRF movies in smFRET experiments. 
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45. loadDWT, saveDWT: load and save .dwt files to disk.  
46. dwtToIdl, idlToDwt: convert dwell-time series to an idealization (state assignments), and vice versa. 
47. qub_loadModel, qub_saveModel, qub_createModel: loade and save .qmf QuB model files. 
48. qub_loadTree, qub_saveTree: direct access to QuB binary files (include .qmf).  

 
Compatibility with file formats used by other programs:  
49. forHammy: export data in a .traces file to a format the HaMMy software can load. 
50. hammyToDWT: convert the output of HaMMy to a .dwt file. 
51. forvbFRET: export data in a .traces file to a format the vbFRET software can load.  
52. vbFRET_dwt: convert the output of vbFRET to a .dwt file. 
53. forQuB: export data in a .qub.txt file to be loaded into the QuB software. 
54. tracesToTxt: export data in a .traces file to a .txt file. 
55. tracesToMat: export data in a .traces file to a .mat file for importing into other software. 
56. cy5ForQuB: convert Cy5 fluorescence data into a format that can be read by QuB. 
 
Other: 
57. getFile, getFiles, getFileGroups: ask the user to select a list of files and return them as a cell array. 
58. haranfilter: filter traces to remove noise while preserving anti-correlated transitions.  
59. combineDatasets: combine traces from multiple .traces files.  
60. loadTraces, saveTraces: load and save trace data to a binary format for fast access.  
61. sizeTraces: determine the number and length of traces in a file without loading the full file.  
62. resizeTraces: truncate all traces within a file. Useful for ensuring all files have the same length. 
63. rebintraces: simulate lower time resolution by time binning. (somewhat outdated) 
64. avgfret: get an average FRET value across all traces in a file. 
 
Classes: 
65. Movie, Movie_STK, Movie_TIFF: classes for loading movie data from disk. 
66. Traces: abstract class that defines a generic collection of trace data and metadata. 
67. TracesFret: class defining a collection 2-color fluorescence- and FRET-time traces. 
68. TracesFret4: class defining a collection of multicolor fluorescence- and FRET-time traces. 
69. QubModel: object representing a Markov model, including emission and kinetic parameters. 
70. QubModelViewer: GUI methods for displaying a model, as in batchKinetics and simulate. 
 
Pre-steady-state analysis: 
rtdgui: user interface for setting parameters and selecting data for automated analysis. 
rtdPlots: command-line tool for recreating plots for data analyzed by rtdgui or rtdTool.  
rtdTool: command-line backend function used for all computation in the above. 
postSyncTraces: iterative post-synchronization of FRET events based on two-state model. 
simplePostSync: simple, threshold-based post-synchronization of FRET traces. 
stateMin: classify FRET events as productive or non-productive. 
stateOccupancy: calculate the occupancy of each state as a function of time. 
 
Compiled (mex) functions: medianfilterx, forward_viterbix, qub_loadTree, qub_saveTree. 
These functions are compiled in C for speed and feature platform-specific versions. 
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Appendix B. File formats 

The various file formats used in the analysis pipeline are listed here for reference. 
 
1. TIFF stacks from wide-field fluorescence movies (.stk, .tif) 
Movies are standard TIFF format image stacks (.tif) or MetaMorph specialized TIFF files (.stk): 
https://en.wikipedia.org/wiki/Tagged_Image_File_Format 
ftp://ftp.meta.moleculardevices.com/support/stack/STK.doc 

 
2. Binary fluorescence traces file format (.traces and .rawtraces) 
A specialized binary format is used for saving all trace data to facilitate fast loading and saving of data 
from disk. All of this information is available in a Traces object when loading a file with loadTraces. 
 

struct TracesFile { 

uint32 zero = 0 

char[4] signature = “TRCS” 

uint16 version = 5 

uint8 dataType = enum( 9=single ) 

uint8 nChannels = C, number of data channels (usually 3) 

uint32 nTraces = N, number of particles (traces) 

uint32 nFrames = M, number of data points per trace 

 

uint16 chNameLen = length of the following char array 

char[*] chNames = channel names, delimited by char(31) 

 

dataType[M] time = acquisition time axis (in milliseconds) 

dataType[N×M] channel1 = donor fluorescence 

dataType[N×M] channel2 = acceptor fluorescence 

dataType[N×M] channel3 = FRET 

 

MetadataField root = struct-type metadata field containing 

fileMetadata and traceMetadata children. 

} 

 
dataType is an enum (starting with zero): char, uint8, uint16, uint32, uint64, int8, int16, int32, int64, 
single, double, logical, cell array, and struct. Metadata fields have the following structure: 
 

struct MetadataField { 

uint8 dataType = enum of metadata type (see above) 

uint32 fieldSize = length in bytes of entire metadata page 

 

uint8 nameLen = Length of the text string below 

char[*] fieldName = tag name for this metadata field 

 

uint8 ndim = Number of dimensions listed below 

uint32 dataSize = List of dimensions of the metadata array 

 

dataType[…] contents = actual metadata content [dataSize] array 

} 

 

https://en.wikipedia.org/wiki/Tagged_Image_File_Format
ftp://ftp.meta.moleculardevices.com/support/stack/STK.doc
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Struct-type contents have the following format: 
 

struct StructContents {  

uint8 nFields = Number of fields in the struct 

  

uint8 nameLen = Length of the text string below 

char[*] fieldName = struct field name 

uint8 isPacked = true if contents are compressed 

MetadataField contents = one element per array element 

 

… (last four fields are repeated nFields times) 

} 

 
If all elements in a field are the same type, they are packed together into a single MetadataField 
element. Char types are packed into one contiguous string delimited by char(31). Numeric and logical 
types are packed into a matrix concatenated along a new final dimension. 
 
Metadata fields are separated into two groups. “fileMetadata” fields apply to all traces in the file, 
including a list of wavelengths for each spectral channel (e.g., [532 640]). “traceMetadata” is an array 
with one value per trace, including unique identifier strings (“ids”) and Cartesian coordinates of PSF 
locations within the field-of-view for each spectral channel (e.g., “donor_x” and “donor_y”). Identifiers 
are typically the movie file name and trace number in the original .rawtraces file (e.g., 
“E:\Folder\test_movie.tif#123”). 
 
3. Dwell-times text file format (.dwt) 
FRET idealization traces (state assignment at each point in time) are stored in the .dwt format files 
recognized by QuB. A .dwt file is a list of dwell-times grouped into segments that generally correspond 
to distinct traces. Dwell-time sequences represent an idealization generated using Hidden Markov 
Modeling algorithms (see Section VI). Each segment has the following format: 

 
Segment: 1 Dwells: 5 Sampling(ms): 25 Start(ms): 0 ClassCount: N µ1 σ1 µ2 σ2 … 

2 150 

1 25 

2 350 

0 75 

2 100 

 
The first line identifies the beginning of a segment (idealized region, typically the beginning of a trace). 
Segments are numbered sequentially (first number). The header line includes the number of dwells 
that follow, the time resolution, the starting point of this segment within the linearized FRET data, and 
the number of distinct FRET states (classes). The end of the header includes a list of parameters used 
for idealization: ”µ1 σ1 µ2 σ2 … µN σN”, where µi and σi are the mean and standard deviations of 
FRET). A list of dwells follows, one per line, with the class number of the state and the duration of the 
dwell in milliseconds. Note that class numbers start with 0 in the file, but start with 1 in MATLAB (for 



32 

 

example using loadDWT and saveDWT).  Offsets (listed under “Start(ms)”) establish a correspondence 
between FRET data and the idealization. Also see:  
http://www.qub.buffalo.edu/qubdoc/files/dwt.html 
 
4. forQuB text format (.qub.txt) 
This text format is used when importing data into QuB. It is a simple list of FRET values, with all traces 
concatenated together. The traces should then be segmented in QuB. 
 
5. qubtree binary format (.qmf, etc.) 
Some information is saved in a binary format that was originally developed for QuB. This includes 
HMM model files (.qmf). The data are represented in a tree of named fields. The format is supported 
with the qub_loadTree and qub_saveTree functions. See the following link for further details.  
http://www.qub.buffalo.edu/qubdoc/qubtree/contents.html 
 
 
 

  

http://www.qub.buffalo.edu/qubdoc/files/dwt.html
http://www.qub.buffalo.edu/qubdoc/qubtree/contents.html
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Appendix C. Compiled functions (.mex files) 
Some functions are written in C/C++ and compiled as binary libraries supported by MATLAB (.mex 
files). Unlike .m files that are platform independent, .mex files must be compiled for each targeted 
operating system and computer architecture. These files and any supporting libraries can be found in 
the “binary” directory in the source code. 
 
1) medianfilterx.mex: is a function used by calcLifetime and traceStat for the autotrace program to 

speed up the computation of median filtering. A platform independent version is also available as a 
fallback (medianfilter.m). Source code and compiling instructions can be found in the 
“medianfilter” directory of the source code. 
 

2) qub_loadTree and qub_saveTree: are functions written in C/C++ to support the “qubtree” format 
that is used for many output files from QuB, including model definitions (.qmf files). The source 
code for these functions can be found in the “qub” directory. The “treestruct.cpp” file contains 
functions for interfacing between MATLAB and the QuB source code. The necessary QuB source 
code files for compiling the qubtree library are available in the qubtree subdirectory. 
http://www.qub.buffalo.edu/qubdoc/ 

 
3) forward_viterbix.mex: is a compiled implementation of the Viterbi algorithm [5] for finding the 

optimal state sequence (idealization) given FRET data and a fixed model. This function is used by 
the idealize and skm functions. Source code, which consists of the forward_viterbix.cpp file, can be 
found in the “HMM” directory. A forward_viterbi.m fallback version is also available. 

 

4) gillespiex.mex: compiled implementation of the Gillespie stochastic simulation algorithm used by 
the simulate function. (A non-compiled version gillespie.m is also available as a fallback.) 

  
5) miltreeiface: is a command line executable version of the maximum interval likelihood (MIL) model 

optimization procedure in QuB [7, 9]. This is used by batchKinetics. Currently no supported on Mac 
OS. 
http://www.qub.buffalo.edu/wiki/index.php/Modeling:MIL 
 

 
  

http://www.qub.buffalo.edu/qubdoc/
http://www.qub.buffalo.edu/wiki/index.php/Modeling:MIL
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